const regex = /\A(?:(?=(?(3)[\s\S]*(?=\3\z))(?|.(?=.*\n(\1?+.).*\n(\2?+.))|.*\n()())+?(?<=X)(?=.*\n\1(?<=X).*\n\2(?<=X))(?=([\s\S]*\z)))(?=[\s\S]*([\s\S](?(4)\4)))[\s\S])+[\s\S]*(?=\4\z)|\G(?!\A|[\s\S]?\z)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\A(?:(?=(?(3)[\\s\\S]*(?=\\3\\z))(?|.(?=.*\\n(\\1?+.).*\\n(\\2?+.))|.*\\n()())+?(?<=X)(?=.*\\n\\1(?<=X).*\\n\\2(?<=X))(?=([\\s\\S]*\\z)))(?=[\\s\\S]*([\\s\\S](?(4)\\4)))[\\s\\S])+[\\s\\S]*(?=\\4\\z)|\\G(?!\\A|[\\s\\S]?\\z)', 'gm')
const str = `....X.......
..X..X...X....
X.X...X..X.....
X....XXXXXX.....
X..XXX...........
.....X..........
..............X
..X...........X....
..X...........X....X...
....X.....`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}