import re
regex = re.compile(r"\A(?:(?=(?(3)[\s\S]*(?=\3\z))(?|.(?=.*\n(\1?+.).*\n(\2?+.))|.*\n()())+?(?<=X)(?=.*\n\1(?<=X).*\n\2(?<=X))(?=([\s\S]*\z)))(?=[\s\S]*([\s\S](?(4)\4)))[\s\S])+[\s\S]*(?=\4\z)|\G(?!\A|[\s\S]?\z)", flags=re.MULTILINE)
test_str = ("....X.......\n"
"..X..X...X....\n"
"X.X...X..X.....\n"
"X....XXXXXX.....\n"
"X..XXX...........\n"
".....X..........\n"
"..............X\n"
"..X...........X....\n"
"..X...........X....X...\n"
"....X.....")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")