import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:File:.*(\\ |\\,)\\.(png|gif|jpe?g|tiff?|xcf|pdf|mid|ogg|ogv|svg|djvu|oga|flac|opus|wav|webm|webp))$";
final String string = "pattern 1\n"
+ "no match\n"
+ "file:foobar.jpg\n"
+ "file:foobar,jpg\n"
+ "file:foobar.jpg,ogg\n"
+ "file:foobar,jpg,ogg\n"
+ "match\n"
+ "file:foobar,jpg.ogg\n"
+ "file:foobar.jpg.ogg\n\n"
+ "pattern 2\n"
+ "no match\n"
+ "file:foobar.jpg\n"
+ "file:foobar,jpg\n"
+ "file:foobar. jpg\n"
+ "file:foobar, jpg\n"
+ "file:foobar.,jpg\n"
+ "file:foobar ,jpg\n"
+ "match\n"
+ "file:foobar .jpg\n"
+ "file:foobar,.jpg\n\n"
+ "both pattern 1 and 2 match\n"
+ "file:foobar.webm,.tif\n"
+ "file:foobar.ogv .pdf\n"
+ "file:foobar,wav .flac\n\n"
+ "file:Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat. Duis aute irure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla pariatur. Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum.jpg";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE | Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}