const regex = /^(?:File:.*(\ |\,)\.(png|gif|jpe?g|tiff?|xcf|pdf|mid|ogg|ogv|svg|djvu|oga|flac|opus|wav|webm|webp))$/uimg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:File:.*(\\ |\\,)\\.(png|gif|jpe?g|tiff?|xcf|pdf|mid|ogg|ogv|svg|djvu|oga|flac|opus|wav|webm|webp))$', 'uimg')
const str = `pattern 1
no match
file:foobar.jpg
file:foobar,jpg
file:foobar.jpg,ogg
file:foobar,jpg,ogg
match
file:foobar,jpg.ogg
file:foobar.jpg.ogg
pattern 2
no match
file:foobar.jpg
file:foobar,jpg
file:foobar. jpg
file:foobar, jpg
file:foobar.,jpg
file:foobar ,jpg
match
file:foobar .jpg
file:foobar,.jpg
both pattern 1 and 2 match
file:foobar.webm,.tif
file:foobar.ogv .pdf
file:foobar,wav .flac
file:Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat. Duis aute irure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla pariatur. Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum.jpg`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}