// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?uim)^(?:File:.*(\ |\,)\.(png|gif|jpe?g|tiff?|xcf|pdf|mid|ogg|ogv|svg|djvu|oga|flac|opus|wav|webm|webp))$").unwrap();
let string = "pattern 1
no match
file:foobar.jpg
file:foobar,jpg
file:foobar.jpg,ogg
file:foobar,jpg,ogg
match
file:foobar,jpg.ogg
file:foobar.jpg.ogg
pattern 2
no match
file:foobar.jpg
file:foobar,jpg
file:foobar. jpg
file:foobar, jpg
file:foobar.,jpg
file:foobar ,jpg
match
file:foobar .jpg
file:foobar,.jpg
both pattern 1 and 2 match
file:foobar.webm,.tif
file:foobar.ogv .pdf
file:foobar,wav .flac
file:Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat. Duis aute irure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla pariatur. Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum.jpg";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}