# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:File:.*(\ |\,)\.(png|gif|jpe?g|tiff?|xcf|pdf|mid|ogg|ogv|svg|djvu|oga|flac|opus|wav|webm|webp))$"
test_str = ("pattern 1\n"
"no match\n"
"file:foobar.jpg\n"
"file:foobar,jpg\n"
"file:foobar.jpg,ogg\n"
"file:foobar,jpg,ogg\n"
"match\n"
"file:foobar,jpg.ogg\n"
"file:foobar.jpg.ogg\n\n"
"pattern 2\n"
"no match\n"
"file:foobar.jpg\n"
"file:foobar,jpg\n"
"file:foobar. jpg\n"
"file:foobar, jpg\n"
"file:foobar.,jpg\n"
"file:foobar ,jpg\n"
"match\n"
"file:foobar .jpg\n"
"file:foobar,.jpg\n\n"
"both pattern 1 and 2 match\n"
"file:foobar.webm,.tif\n"
"file:foobar.ogv .pdf\n"
"file:foobar,wav .flac\n\n"
"file:Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat. Duis aute irure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla pariatur. Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum.jpg")
matches = re.finditer(regex, test_str, re.UNICODE | re.IGNORECASE | re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.