#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\<errorCode>(?<errorCode>[^\<]*)\<\/errorCode>"
Local $sString = "<createUser>" & @CRLF & _
" <errorCode>abc</errorCode>" & @CRLF & _
"</createUser>" & @CRLF & _
"" & @CRLF & _
"<deleteUser>" & @CRLF & _
" <errorCode>xyz</errorCode>" & @CRLF & _
"</deleteUser>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")