package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\<errorCode>(?<errorCode>[^\<]*)\<\/errorCode>`)
var str = `<createUser>
<errorCode>abc</errorCode>
</createUser>
<deleteUser>
<errorCode>xyz</errorCode>
</deleteUser>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}