$re = '/\<errorCode>(?<errorCode>[^\<]*)\<\/errorCode>/';
$str = '<createUser>
<errorCode>abc</errorCode>
</createUser>
<deleteUser>
<errorCode>xyz</errorCode>
</deleteUser>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);