using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\<errorCode>(?<errorCode>[^\<]*)\<\/errorCode>";
string input = @"<createUser>
<errorCode>abc</errorCode>
</createUser>
<deleteUser>
<errorCode>xyz</errorCode>
</deleteUser>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}