$re = '/^(?=.*[A-Z])(?=.*[a-z])(?=.*[0-9])[a-zA-Z0-9_]{3,}$/m';
$str = 'qwer1234
qweQWE123
123
qwe
eifajdjf2123^%*(1sfjijda2(
1qaz2wsx3edc
qweQWE
QWE';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);