import re
regex = re.compile(r"^(?=.*[A-Z])(?=.*[a-z])(?=.*[0-9])[a-zA-Z0-9_]{3,}$", flags=re.MULTILINE)
test_str = ("qwer1234\n"
"qweQWE123\n"
"123\n"
"qwe\n"
"eifajdjf2123^%*(1sfjijda2(\n"
"1qaz2wsx3edc\n"
"qweQWE\n"
"QWE")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")