re = /^(?=.*[A-Z])(?=.*[a-z])(?=.*[0-9])[a-zA-Z0-9_]{3,}$/m
str = 'qwer1234
qweQWE123
123
qwe
eifajdjf2123^%*(1sfjijda2(
1qaz2wsx3edc
qweQWE
QWE'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end