const regex = new RegExp(', (?=et al\\.)', 'g')
const str = `(Jennings, et al., 2013; Ritchie, et al., 2012)`;
const subst = `\ `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);