$re = '~, (?=et al\.)~';
$str = '(Jennings, et al., 2013; Ritchie, et al., 2012)';
$subst = "\ ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;