import re
regex = re.compile(r", (?=et al\.)")
test_str = "(Jennings, et al., 2013; Ritchie, et al., 2012)"
subst = "\\ "
result = regex.sub(subst, test_str)
if result:
print(result)