import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\s)\\d(?=\\d{0,4}-)(?:-?\\d){5}(?=\\s)";
final String string = "то есть, матчится:\n"
+ "111-111\n"
+ "11-1111\n"
+ "1-111-11\n\n"
+ "не матчится:\n"
+ "111111\n"
+ "-111111\n"
+ "111111-\n"
+ "111--111\n"
+ "11-11\n"
+ "1111-1111\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}