re = /(?<=\s)\d(?=\d{0,4}-)(?:-?\d){5}(?=\s)/
str = 'то есть, матчится:
111-111
11-1111
1-111-11
не матчится:
111111
-111111
111111-
111--111
11-11
1111-1111
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end