import Foundation
let pattern = #"(?<=\s)\d(?=\d{0,4}-)(?:-?\d){5}(?=\s)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
то есть, матчится:
111-111
11-1111
1-111-11
не матчится:
111111
-111111
111111-
111--111
11-11
1111-1111
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)