use strict;
my $str = 'то есть, матчится:
111-111
11-1111
1-111-11
не матчится:
111111
-111111
111111-
111--111
11-11
1111-1111
';
my $regex = qr/(?<=\s)\d(?=\d{0,4}-)(?:-?\d){5}(?=\s)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}