using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\d.]+)\s([\d.]+)\s([\d.]+)\s([\d.]+)\s([\d.]+)";
string input = @"104.99 0.00 0.00 0.00 0.00";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}