re = /([\d.]+)\s([\d.]+)\s([\d.]+)\s([\d.]+)\s([\d.]+)/m
str = '104.99 0.00 0.00 0.00 0.00'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end