$re = '/([\d.]+)\s([\d.]+)\s([\d.]+)\s([\d.]+)\s([\d.]+)/m';
$str = '104.99 0.00 0.00 0.00 0.00';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);