package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\s(?<area>\d{3})(?<prefix>\d{3})(?<suffix>\d{4})$`)
var str = `VM from CALLERIDNAME 8008675309`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}