const regex = /\s(?<area>\d{3})(?<prefix>\d{3})(?<suffix>\d{4})$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s(?<area>\\d{3})(?<prefix>\\d{3})(?<suffix>\\d{4})$', '')
const str = `VM from CALLERIDNAME 8008675309`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}