re = /\s(?<area>\d{3})(?<prefix>\d{3})(?<suffix>\d{4})$/
str = 'VM from CALLERIDNAME 8008675309'
# Print the match result
str.match(re) do |match|
puts match.to_s
end