$re = '/\s(?<area>\d{3})(?<prefix>\d{3})(?<suffix>\d{4})$/';
$str = 'VM from CALLERIDNAME 8008675309';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);