import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\+\\d{2,4})?\\s?(\\d{2,4}|\\(\\d{2,4}\\))?\\s?[\\d\\s.-]{3,15}$";
final String string = "9999 99999-99\n"
+ "+99 999288432\n"
+ "(883) 892739723\n"
+ "+12 123 8293-76.238\n"
+ "123 234 879347-837";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}