import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\bPlease\\b)(?!.*\\1)";
final String string = "This email is unabliabe. Please \"sent fdfds;lfk\"\n"
+ "This email is send. \"Please\" sent f;dlskf\n"
+ "This email have been send to you. Please Please fdsfsf";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}