# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[^\s-]\K-\s{1,3}//gm;t' <<< "The number of spaces after the hyphen can be 1, 2 or 3 like hyphen- ated, hyphen- ated, hyphen- ated .
This is a text with a hyphen- ated word in the middle of the sentence. But it also has - dashes - like the ones in the second sentence. The latter should not be modified"