import Foundation
let pattern = #"[^\s-]\K-\s{1,3}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
The number of spaces after the hyphen can be 1, 2 or 3 like hyphen- ated, hyphen- ated, hyphen- ated .
This is a text with a hyphen- ated word in the middle of the sentence. But it also has - dashes - like the ones in the second sentence. The latter should not be modified
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)