# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[^\s-]\K-\s{1,3}"
test_str = ("The number of spaces after the hyphen can be 1, 2 or 3 like hyphen- ated, hyphen- ated, hyphen- ated .\n\n"
"This is a text with a hyphen- ated word in the middle of the sentence. But it also has - dashes - like the ones in the second sentence. The latter should not be modified")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.