const regex = new RegExp('Grade = (\\d+)', 'g')
const str = `Grade = 2`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);