use strict;
my $str = 'Grade = 2';
my $regex = qr/Grade = (\d+)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";