using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"V:\\Flying Probe\\TESTDATA\\(.+)-FULL_|-Tented_|-panel_[a-zA-Z ]+\.txt";
string substitution = @"";
string input = @" V:\Flying Probe\TESTDATA\278995-1-FULL_Certification.txt
V:\Flying Probe\TESTDATA\278995-1-FULL_Test Results.txt";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}