# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"V:\\Flying Probe\\TESTDATA\\(.+)-FULL_|-Tented_|-panel_[a-zA-Z ]+\.txt"
test_str = (" V:\\Flying Probe\\TESTDATA\\278995-1-FULL_Certification.txt\n"
"V:\\Flying Probe\\TESTDATA\\278995-1-FULL_Test Results.txt")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.