import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "V:\\\\Flying Probe\\\\TESTDATA\\\\(.+)-FULL_|-Tented_|-panel_[a-zA-Z ]+\\.txt";
final String string = " V:\\Flying Probe\\TESTDATA\\278995-1-FULL_Certification.txt\n"
+ "V:\\Flying Probe\\TESTDATA\\278995-1-FULL_Test Results.txt";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}