#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:\b|\s+)(?:dutch|brown)(?:\s+|\b)"
Local $sString = "dutch dutch brown" & @CRLF & _
"brown " & @CRLF & _
"AAdutch" & @CRLF & _
"dutchAA" & @CRLF & _
"AAbrown" & @CRLF & _
"brownAA" & @CRLF & _
"hello"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")