re = /(?:\b|\s+)(?:dutch|brown)(?:\s+|\b)/m
str = 'dutch dutch brown
brown
AAdutch
dutchAA
AAbrown
brownAA
hello'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end