using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\b|\s+)(?:dutch|brown)(?:\s+|\b)";
string input = @"dutch dutch brown
brown
AAdutch
dutchAA
AAbrown
brownAA
hello";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}