$re = '/(?:\b|\s+)(?:dutch|brown)(?:\s+|\b)/m';
$str = 'dutch dutch brown
brown
AAdutch
dutchAA
AAbrown
brownAA
hello';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);