using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)^(?:foo|bar) (?:(?:[a-z\d'.-](?<!['.-]{2})){1,7} ){1,5}\w{1,7}$";
string input = @"foo Brian M. O'Dan Darwin
foo Brian M.. ODan Darwin
foo Brian M. O'-Dan Darwin
foo Brian M. O'Dan Darwin";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}