$re = '/(?i)^(?:foo|bar) (?:(?:[a-z\d\'.-](?<![\'.-]{2})){1,7} ){1,5}\w{1,7}$/m';
$str = 'foo Brian M. O\'Dan Darwin
foo Brian M.. ODan Darwin
foo Brian M. O\'-Dan Darwin
foo Brian M. O\'Dan Darwin';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);