import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)^(?:foo|bar) (?:(?:[a-z\\d'.-](?<!['.-]{2})){1,7} ){1,5}\\w{1,7}$";
final String string = "foo Brian M. O'Dan Darwin\n\n"
+ "foo Brian M.. ODan Darwin\n"
+ "foo Brian M. O'-Dan Darwin\n"
+ "foo Brian M. O'Dan Darwin";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}