#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!\d)\d{2}\D*\d{8}\D*\d(?!\d)"
Local $sString = "Shoud match:" & @CRLF & _
"11 11111111 1" & @CRLF & _
"11-11111111-1" & @CRLF & _
"11.11111111.1" & @CRLF & _
"11|11111111|1" & @CRLF & _
"11.11111111 1" & @CRLF & _
"11 11111111 1" & @CRLF & _
"" & @CRLF & _
"Shoud not match" & @CRLF & _
"11 11111111 11" & @CRLF & _
"1 11111111 11" & @CRLF & _
"111111111111111111111111"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")