using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\d)\d{2}\D*\d{8}\D*\d(?!\d)";
string input = @"Shoud match:
11 11111111 1
11-11111111-1
11.11111111.1
11|11111111|1
11.11111111 1
11 11111111 1
Shoud not match
11 11111111 11
1 11111111 11
111111111111111111111111";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}