import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\d)\\d{2}\\D*\\d{8}\\D*\\d(?!\\d)";
final String string = "Shoud match:\n"
+ "11 11111111 1\n"
+ "11-11111111-1\n"
+ "11.11111111.1\n"
+ "11|11111111|1\n"
+ "11.11111111 1\n"
+ "11 11111111 1\n\n"
+ "Shoud not match\n"
+ "11 11111111 11\n"
+ "1 11111111 11\n"
+ "111111111111111111111111";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}