$re = '/(?<!\d)\d{2}\D*\d{8}\D*\d(?!\d)/m';
$str = 'Shoud match:
11 11111111 1
11-11111111-1
11.11111111.1
11|11111111|1
11.11111111 1
11 11111111 1
Shoud not match
11 11111111 11
1 11111111 11
111111111111111111111111';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);