$re = '/\s*\b(?!N=\d)\w+=\d+/m';
$str = 'P=32 N=5 M=2';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;