import re
regex = re.compile(r"\s*\b(?!N=\d)\w+=\d+", flags=re.MULTILINE)
test_str = "P=32 N=5 M=2"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)